
 
Animate - Fly Swatter Tutorial 

 

-Open Animate 
-Under Create New - Select ActionScript 3.0  
 

 

-Choose Classic as the Design type located in the 
upper right corner 
 

 

 

-Animate workspace shows a toolbar, timeline, stage, and window tabs 
 

 
 
-From the top menus, choose File>Save As 
-Save the file name as last name + first initial + flies.fla 
-Save as a .fla file extension in your Animate folder, make sure file format at bottom of window shows as 
Animate Document (*.fla) 

 
-Remember to always hit Command + S every time you make a change to your project going forward. 



 
Animate - Fly Swatter Tutorial 

-The Properties window is located on the right 
-Leave the preset for the Stage at: 
       Size is 550W x 400H pixels 
       Frame Rate (FPS) = 24 FPS 
 

 
 

-In the Properties window, choose a Stage color for 
the sky color, by clicking on the white color box 
located to the right of the word Stage 
 

 

 

-At the bottom of the Toolbar, locate the two color 
squares. These are the Stroke (outline) and Fill 
(color inside a shape) color swatches. 
 

 

-Click the Stoke color box (Stroke has a pencil with a 
color box below), and the color swatches window 
appears. 
-Select the white box with a red diagonal line in it, 
located in the top right of the color swatches window, 
next to the Alpha.  This means NO STROKE. 
 

 

-Click the Fill color box (Fill has a tipped paint bucket 
pouring out a with color box below) 
-Select a color for the fly swatter, any color other 
than the same color as your background. 
 

 

-On the Toolbar, select the Rectangle Tool (R) 

 
 
-Place the mouse on the Stage and left click and 
drag out a narrow rectangle shape, for the swatter 
handle, near the center of the bottom of the Stage 
 

 



 
Animate - Fly Swatter Tutorial 

-The Timeline will now show a solid black dot on 
frame 1 of Layer 1. This is solid black dot is called a 
KEYFRAME​. 
 

 

-On the Toolbar, select the PolyStar Tool 

 
 
-Place the mouse on the upper Stage and left click 
and drag out a pentagon shape, for the swatter head, 
near the center of the top of the Stage, but not 
touching the handle 
 

 

-On the Toolbar, select the Free Transform Tool (Q) 

 
 
-Click on the swatter head on the stage.  Will see a 
transform box around the shape. 
 

 

-Hold shift and drag only from the corners to scale 
the swatter head down 
-Use arrow keys to move the swatter head on top of 
the swatter handle 
 

 
 
 



 
Animate - Fly Swatter Tutorial 

-On the Toolbar, select the Line Tool (N) 

 
 
-Choose black or white as the fill color 
-Draw angled lines on the swatter, to form a pattern 
similar to what is found on the head of a fly swatter 
 

 

-Command (+) to zoom in on the Stage 
-On the Toolbar, select the Selection Tool (V) 

 
 
-Place the mouse on the Stage about midway down 
the swatter handle, against the left edge.  An arrow 
with a curve below it will show. 
-Click and drag the left side handle edge to the left, 
and it will curve out the left side edge. 
 

 
 
 

-Place the mouse on the Stage about midway down 
the handle, against the right edge.  An arrow with a 
curve below it will show. 
-Click and drag the right side handle edge to the left, 
and it will curve in the right side edge, giving the 
handle an overall curved appearance. 
 

 

-On the Toolbar, make sure the Selection Tool (V) is 
still selected 
-Place the mouse on the Stage in the upper left and 
click, hold, drag a marquee box around the entire 
swatter.  This will put a temporary highlight box 
around the swatter, that will disappear when you let 
go. 
 
*It is important to get the entire swatter, so drag 
the box off the stage when selecting to make 
sure to get entire handle. 

 



 
Animate - Fly Swatter Tutorial 

-The entire swatter is now covered in tiny dots which 
mean it is a selected shape. 
-To animate, we need to convert it to a symbol 
-Place the mouse on top of the swatter on the Stage  
-Right Click > Convert to Symbol (F8) 
 

 

-Convert to Symbol window opens 
 

 

-Name: Swatter 
-Type: Movie Clip 
-Registration: Black dot should be center square 
-Click OK 
 

 
 
 

-The selection dots on the swatter disappear as the 
object is no longer a shape 
-A thin blue outline box now appears around the 
entire swatter showing that it is now a symbol 
 

 



 
Animate - Fly Swatter Tutorial 

-Click on frame 60 of Layer 1 in the Timeline to 
highlight the frame 
 

 
 
-Right click > Insert Frame (F5) 
-This places a small square on frame 60 in the 
Timeline and tells Animate to keep this object on the 
Stage for 60 frames. 
 

 

-Click on the square icon to left of the word Layer 1 
in the Timeline 

 
 
-All frames from 1 to 60 on Layer 1 will now highlight 
 
-Position the mouse anywhere in the highlighted 
frames below the numbers on Layer 1  
-Right click > Create Motion Tween 
 

 

-Click in the grey area below Layer 1 in the Timeline 
to deselect the layer 
-Frames 1-60 on Layer 1 are now highlighted blue, 
indicating the motion tween area 
 

 
 

-Click on Keyframe 1 on Layer 1 to highlight and 
select it 
 

 

-On the Toolbar, select the Free Transform Tool (Q) 

 
 
-A transform box will appear around the swatter on 
the Stage, and a white dot will be in the center of the 
transform box 

 

-The white dot is the anchor point, the point from 
which the object rotates 
-Click the white dot in the center of the transform box 
and drag it straight down, below the bottom of the 
swatter handle into the grey area just off the Stage 
 

 

                        ↗ 



 
Animate - Fly Swatter Tutorial 

-Move the mouse to the outside of the transform box, 
just outside the upper right corner, and an arrow with 
a curved arrow below it will appear 
-Make sure only keyframe 1 on Layer 1 is still 
selected 
-Using the curved arrow that appears, tilt the swatter 
to the right by dragging the mouse to the right. The 
swatter will rotate by the anchor point (white dot) at 
the bottom of the Stage 
 

 

-Click in the grey area below Layer 1 in the Timeline 
to deselect keyframe 1 
 

 
 
-In the Timeline, click on frame 15 to highlight and 
select it 
 

 
 

-DO NOT INSERT A KEYFRAME 
-Make sure only frame 15 is highlighted 
-Make sure Free Transform tool still selected 
-Move the mouse onto the Stage, place cursor just 
outside right edge, and rotate the swatter to the left 
 

 

-The movement of the swatter on the stage will 
create a keyframe in the Timeline on frame 15 for the 
path of movement 
 

 
 
-Randomly select frames either 10 or 15 frames 
apart in the Timeline and rotate the swatter on the 
stage to the opposite side each time, all the way to 
the 60 frame point. 
-Remember to deselect the layer (by clicking below 
the Layer in the Timeline) each time before selecting 
the next frame in the Timeline for movement 
 
 
 
 



 
Animate - Fly Swatter Tutorial 

-Have the swatter make a big swat at the end by the 
time it reaches frame 60 
-Make sure the swatter ends up on the same side 
direction (right) as it started on frame 1 for frame 60 
-Should have around 5-7 keyframes for the layer, but 
be creative and use more if necessary 
 
-Label the Layer Swatter, by double clicking on the 
word (Layer 1) in the timeline and typing in the name. 
-Hit Return. 
-Lock the Layer 
 

 
 

 

-Hit Command + Return to see a looping preview the 
animation as a SWF file 
-Click red dot in upper left of the SWF preview 
window to close 
 

 

-Create a new layer by clicking on the New Layer 
button located in the bottom left corner of the 
Timeline. (Similar to new layer button in Photoshop) 

 

 

           ↗ 

-Select a Fill color for the first bug, make sure still 
have NO Stoke 
 

 
 
 



 
Animate - Fly Swatter Tutorial 

-On the Toolbar, select the Oval tool (O) 

 
-Drag out a large oval for the body of the bug. Do not 
worry about size yet. ​DO NOT Draw wings yet. 
 

 
 

-Change the Fill color to black or white and add an 
eye (small oval) to the bug 
 

 
 

-On the toolbar, select the Brush tool (B) 

 
-Draw on any stripes or any markings of choice to 
the body of the bug 
 

 

-On the Toolbar, select the Selection Tool (V) 
-Place the mouse on the Stage in the upper left 
outside the bug, and click, hold, drag a marquee box 
around the entire bug.  This will put a temporary 
highlight box around the bug, that will disappear 
when you let go. 
 

 
 

 

-The entire bug is now covered in tiny dots which 
means it is a selected shape. 

 
-We are going to group the bug to allow for further 
animation and editing abilities 
-From top menus Modify > Group (Command + G) 
 

 



 
Animate - Fly Swatter Tutorial 

-The selection dots on the bug body disappear as the 
object is no longer a shape 
-A thin blue/green outline box now appears around 
the entire bug’s body showing that it is now a group 
 

 

-Set Stroke to No Stroke 
-Set Fill to a Grey color, but leave color picker open 
 

 
 

-Change the Alpha of the Fill color (located in the 
upper right corner of the color picker window) to 75% 
-This will be used for the wings so to slightly see 
through them. (Alpha is similar to Opacity in 
Photoshop) 
 

 

-On the Toolbar, select the Oval Tool (O) 
-Drag out an elongated oval for the first wing 
-It will appear behind the bug body when you draw 
the wing oval, but you will adjust position and size 
later 
 

 

-On the Toolbar, click the Selection Tool (V) 
-Click on the wing oval 
-The wing oval shows dots as a selected shape 

 

-Modify > Group (Command + G) to group the wing 
-The wing now has blue outline box and it’s position 
is now in front of the bug’s body 

 



 
Animate - Fly Swatter Tutorial 

-On the Toolbar, select the Free Transform tool (Q) 
-The wing will show the transform box with the 
anchor point in the center (white dot) 
 

 

-Single click on the wing and move it into a wing 
position on the bug.  It is ok if the wing is off the 
stage.  That will be adjusted later 
 

 
 
*Do not double click the wing as it will take you 
into a separate timeline. If you do double click, 
the wing will show dots again like a shape. To get 
back, just click on Scene 1 (located below the 
timeline, near the toolbar) to return to the normal 
timeline scene. 
 

 

-Click on the anchor point and move it to bottom 
center of the wing, where it will rotate on the bug’s 
body 
 

 

-On the Stage, place the mouse inside the wing 
-Hold Alt and left click and drag to the right 
-This will make a copy of the first wing, creating the 
second wing 
 

 



 
Animate - Fly Swatter Tutorial 

-On the Stage, place the mouse inside wing 2 
-Right click > Arrange > Send Backward 
-Now wing 1 in front of body and wing 2 behind 
 

 

-On the Stage, move both wings on the bug body to 
a natural position and rotate each wing by putting 
mouse in upper right corner till see curved arrow 
(same way rotated the swatter earlier) 
-Still do not worry if wings go off the stage or the size 
of the bug yet 
 

 

-On the Toolbar, choose the Selection Tool (V) 
-Place the mouse on the Stage and click, hold, drag 
a marquee box around the entire bug and wings. 
This will put a temporary highlight box around the 
bug, that will disappear when you let go. 
 

 

-On the Stage, the bug body and wings each have 
the blue/green grouped boxes around them 
 

 

-On the Stage, place the mouse inside the bug body 
-Right click > Convert to Symbol (F8) 
 

 

-Convert to Symbol window opens 
 

 



 
Animate - Fly Swatter Tutorial 

-Name: Color of Bug (mine would be yellow bug) 
-Type: Movie Clip 
-Registration: Black dot should be center square 
-Click OK 
 

 

-On the Stage, now the entire bug and wings show 
one thin blue/green box around it 
 

 

-On the Toolbar, select the Free Transform Tool (Q) 
-A transform box will appear around entire bug 
 

 

-On the Stage, double click on a wing 
-This will step into the the object and will show a 
separate blank timeline 

 
 
*Note the original Timeline is Scene 1 and the 
symbol is yellow bug (or your color named bug) 
indicated below the Timeline near the toolbar. 
The square with the gear indicates a symbol and 
the director’s clapboard indicates a Scene 
 

 



 
Animate - Fly Swatter Tutorial 

-Click F6 on the keyboard to add 3 new keyframes in 
the Timeline 
-Will now have 4 total keyframe in this separate 
timeline 
 

 

-Click below Layer 1 in the Timeline to deselect all 
keyframes and to deselect the transform box 
showing around the entire bug on the stage 
 

 

-Leave frame 1 and 3 as they are in the Timeline 
-Drag the red rectangle attached to the playhead in 
the Timeline to frame 2 of Layer 1 
 

 

-Make sure Free Transform Tool (Q) still selected  
-On the Stage, click on the left wing 
-Only that wing shows a transform box on Stage 
 

 

-Only frame 2 of Layer 1 is now highlighted in the 
Timeline 

 

-Rotate the wing backward (to left) to a downward 
position 
 

 



 
Animate - Fly Swatter Tutorial 

-On the Stage, still with frame 2 of Layer 1 selected 
in the Timeline, click on the right wing 
-Rotate it forward (to right) to a down position 
 

 

-In the Timeline move the red playhead to frame 4 
 

 

-On the Stage, click on the left wing 
-Rotate the left wing backward again (to left) to a 
downward position 
-On the Stage, click on the right wing 
-Rotate the front wing forward (to right) to a down 
position 
-They do not have to match frame 2 positions as a 
bug’s wings flutter a different positions 
 

 

-In the Timeline, frame 1 and 3 should have wings in 
an upward position and frames 2 and 4 in downward 
position. Adjust wing positions on frames as needed 
if wings flap too far apart. 
-Command + Return to preview the bug with 
fluttering wings 
 

 
 

-Click on Scene 1 to return to the original Timeline 
 

 

            ↗ 

-Command (-) to zoom out to see the full Stage 
-Now can see how big the bug is compared to the 
swatter, so now is when to scale the bug down to 
proper size. 



 
Animate - Fly Swatter Tutorial 

-Select Free Transform tool (Q) 
-Transform box shows around entire bug 
 

 

-Hold Shift and only drag from the corners to scale 
the bug proportionately, without stretching or 
squeezing the object’s size 
 

 

-Click on the square icon to left of the word Layer 2 
in the Timeline 

 
-All frames from 1 to 60 on Layer 2 will now highlight 
 
-Position the mouse anywhere in the highlighted 
frames below the numbers on Layer 2  
-Right click > Create Motion Tween 
 

 

-Click in the grey area below the layers in the 
Timeline to deselect the layer 
-Frames 1-60 on Layer 2 are now highlighted blue, 
indicating the motion tween area 
 

 

-Click on Keyframe 1 on Layer 2 to highlight and 
select it 
 

 

-On the Toolbar, choose the Section Tool (V) 
-Move the bug off to the left of the Stage 
 

 



 
Animate - Fly Swatter Tutorial 

-In the Timeline, click on frame a frame between 5 
and 10 to highlight and select it 
 

 

-On the Stage, move the bug somewhere down and 
towards the swatter 
 

 

-Randomly select frames 5, 10 or 15 frames apart in 
the Timeline and create an up and down path on the 
stage for the bug to fly, all the way to the 60 frame 
point. 
 
-Remember to deselect the layer (by clicking below 
the Layer in the Timeline) each time before selecting 
the next frame in the Timeline for movement 
 
-The total number of keyframes for the bug layer will 
vary depending on your path movement 
 

 

-Make sure the bug misses the swatter at each 
movement and flies off stage at fram 60 
 

 

-To make the path more natural, create curves in the 
path 
-Deselect all keyframes in the Timeline 
-Make sure Selection Tool (V) on Toolbar 
-Place cursor on one of dots of the path on the Stage 
-Cursor will change to arrow with curved line under 
-Now pull up or down to curve the path, similar to 
when curved the swatter handle previously 
 

 

-Create some overlapping loops to simulate the bug 
flying back and forth to avoid the swatter 
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-Label the Layer, Yellow bug (or the color of your 
bug), by double clicking on the word (Layer 2) in the 
timeline and typing in the name.  
-Hit Return. 
-Lock the Layer 
 

 

-Hit Command + Return to see a looping preview the 
animation as a SWF file 
-Click red dot in upper left of the SWF preview 
window to close 
 

 

-Repeat the process to make 2 more bugs/flies, but 
you may add as many as you like (minimum of 3) 
-Make each bug a different color and size 
-Make some bugs come from the opposite side of the 
Stage 
 
-Save the project as a FLA file 
-Export the final project as an SWF file 
-From top menus choose File > Export Movie 

-Make sure titled last name + first initial + flies.swf 
-Save as a .swf file extension in your Animate folder 
-Make sure file format at bottom of save window 
shows as SWF Movie (*.swf) 
 

 
 
-Submit the appropriate file type instructed 

 


